Recent articles (showing 1-10 out of 69):
WARNING: This post has been marked as obsolete and may be incorrect. It is kept for archival purposes only.
To configure Cisco EtherChannel in FreeBSD 7 is relatively simple. We will assume interfaces fxp0 and fxp1 are to be configured into a 200mbps Cisco EtherChannel.
First, we have to load the netgraph modules to support this. Edit /boot/loader.conf and add:
netgraph_load="YES"
ng_socket_load="YES"
ng_fec_load="YES" Copy
Now, the rest of the configuration is done in /etc/rc.conf as follows:
ifconfig_fxp0="up promisc"
ifconfig_fxp1="up promisc"
fec_interfaces="fec0"
fecconfig_fec0="fxp0 fxp1"
ifconfig_fec0="inet 10.0.0.1 netmask 255.0.0.0" Copy
Now, this also requires configuration on the Cisco Switch they plug into. In my configuration, this is a Cisco 3550-24-EMI configured as follows:
interface Port-channel1
description fec0
switchport access vlan 100
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/1
description fec0 [1/2]
switchport access vlan 100
switchport mode access
switchport nonegotiate
channel-group 1 mode on
!
interface FastEthernet0/2
description fec0 [2/2]
switchport access vlan 100
switchport mode access
switchport nonegotiate
channel-group 1 mode on Copy
I've been running this configuration for over a year now with no problems at all, and have tested greater than 100mbps speed to it.